MENU

HDOJ3038 How Many Answers Are Wrong(带权并查集)

2018 年 04 月 20 日 • 阅读: 1458 • 数据结构阅读设置

How Many Answers Are Wrong

  • Time Limit: 2000/1000 MS (Java/Others)
  • Memory Limit: 32768/32768 K (Java/Others)
  • Total Submission(s): 12375
  • Accepted Submission(s): 4417

Problem Description

TT and FF are ... friends. Uh... very very good friends -________-b
FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).
img
Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.
BoringBoringa very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.
The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.
However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.
What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.
But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.
Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.
You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

Source

2009 Multi-University Training Contest 13 - Host by HIT

Recommend

gaojie

题意

有n个数和m个等式,等式A B S表示第A个数到第B个数的和是S,问这些等式中有多少个是错误的。

题解

使用并查集来维护,将A和B之间的数字之和S理解为B比A-1大S,具体参见代码。其实这题也包含了向量思维,比POJ1182食物链那道题简单一些。

我们用$sum[x]$表示$x$到父节点$rootx$之间的数字之和。

$rooty \rightarrow rootx = y \rightarrow rootx - y \rightarrow rooty​$
$ y \rightarrow rootx = y \rightarrow x + x \rightarrow rootx$
$rooty \rightarrow rootx = y \rightarrow x + x \rightarrow rootx - y \rightarrow rooty$
$sum[rooty] = sum[x] + sum - sum[y]$

img

img

代码

StatusAccepted
Time62ms
Memory2864kB
Length934
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 200010;
int F[maxn], sum[maxn];

int find(int x)
{
    if (x == F[x])
        return x;
    int tmp = find(F[x]);
    sum[x] += sum[F[x]]; // 更新
    F[x] = tmp;
    return F[x];
}

int main()
{
    int n, m, x, y, val, cnt;
    while (~scanf("%d%d", &n, &m))
    {
        cnt = 0;
        for (int i = 0; i <= n; ++i)
        {
            F[i] = i;
            sum[i] = 0;
        }
        for (int i = 0; i < m; ++i)
        {
            scanf("%d%d%d", &x, &y, &val);
            x -= 1;
            int fx = find(x), fy = find(y);
            if (fx != fy)
            {
                F[fy] = fx; // 以fx为父节点
                sum[fy] = sum[x] - sum[y] + val; // sum值进行更新
            }
            else
            {
                if (sum[y] - sum[x] != val) // 不想等表示错误
                    cnt++;
            }
        }
        printf("%d\n", cnt);
    }
    return 0;
}

这道题相比较而言,还是挺简单的


The end.
018-04-20 星期五
添加新评论

已有 1 条评论
  1. 邝斌巨巨的这句话:将 A 和 B 之间的数字之和 S 理解为 B 比 A-1 大 S,一下就理解了!@(酷)