MENU

POJ2236 Wireless Network(简单并查集)

2018 年 04 月 14 日 • 阅读: 1118 • 数据结构阅读设置

Wireless Network

  • Time Limit: 10000MS
  • Memory Limit: 65536K
  • Total Submissions: 35037
  • Accepted: 14505

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1."O p" (1 <= p <= N), which means repairing computer p.
2."S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source

POJ Monthly,HQM


链接

http://poj.org/problem?id=2236

题意

定义两个规则:

  1. 如果电脑A和B之间的距离小于等于d,那么A和B可以连通
  2. 如果A和C是连通的,B和C是连通的,那么A和B也是连通的

最开始电脑都是坏的,现有两个操作

  1. O p,修复电脑x
  2. S p q,询问电脑p和q是否连通

题解

使用并查集来维护。

  • 如果电脑A和B之间的距离小于等于d且A和B都被修复好了,那么就进行合并
  • 查询的时候判断一下A和B的祖先节点是否是一样的

代码

  • Status:Accepted
  • Time:4657ms
  • Memory:1756kB
  • Length:1872
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int F[maxn];
bool vis[maxn][maxn];
bool use[maxn];
int n, d;

struct Point
{
    int x, y;
}p[maxn];

void init()
{
    memset(vis, 0, sizeof(vis));
    memset(use, 0, sizeof(use));
    for (int i = 0; i < maxn; ++i)
        F[i] = i;
}

int find(int root)
{
    int tmp, son = root;
    while (root != F[root])
        root = F[root];
    while (son != root)
    {
        tmp = F[son];
        F[son] = root;
        son = tmp;
    }
    return root;
}

void join(int u, int v)
{
    int fu = find(u);
    int fv = find(v);
    if (fu != fv)
        F[fu] = fv;
}

bool IsCom(Point u, Point v) // 判断距离
{
    if ((u.y - v.y) * (u.y - v.y) + (u.x - v.x) * (u.x - v.x) <= d * d)
        return true;
    return false;
}

int main()
{
    init();
    while (cin >> n >> d)
    {
        for (int i = 1; i <= n; ++i)
            scanf("%d%d", &p[i].x, &p[i].y);
        for (int i = 1; i <= n; ++i) // 预处理
        {
            for (int j = 1; j <= n; ++j)
            {
                if (IsCom(p[i], p[j]))
                    vis[i][j] = true;
            }
        }
        char ch;
        int x, y;
        while (cin >> ch)
        {
            if (ch == 'O')
            {
                scanf("%d", &x);
                if (!use[x])
                {
                    for (int j = 1; j <= n; ++j) // 合并
                    {
                        if (use[j] && vis[x][j])
                            join(x, j);
                    }
                    use[x] = true;
                }
            }
            else
            {
                scanf("%d%d", &x, &y);
                if (find(x) == find(y)) // 查询
                    printf("SUCCESS\n");
                else
                    printf("FAIL\n");
            }
        }
    }
    return 0;
}

感觉自己写的好长好复杂,应该要优化下。


The end.
2018-04-14 星期六
最后编辑于: 2018 年 04 月 15 日