MENU

POJ2449 Remmarguts' Date(k短路/A*+Dijkstra)

2018 年 09 月 09 日 • 阅读: 1160 • 图论阅读设置

Remmarguts' Date

Time Limit: 4000MSMemory Limit: 65536K
Total Submissions: 37019Accepted: 10204

Description

"Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks' head, he told them a story.

"Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission."

"Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)"

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister's help!

DETAILS: UDF's capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince' current place. M muddy directed sideways connect some of the stations. Remmarguts' path to welcome the princess might include the same station twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate.

Input

The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed sideway from A-th station to B-th station with time T.

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).

Output

A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output "-1" (without quotes) instead.

Sample Input

2 2
1 2 5
2 1 4
1 2 2

Sample Output

14

Source

POJ Monthly,Zeyuan Zhu


链接

http://poj.org/problem?id=2449

题意

n个点m条边有向带权图,求s到t的k短路,不能到达输出-1。本题需要特判一下s==t的情况。

题解

K短路模板题,dijkstra加A*算法解决。

对于每个点,都有一个有g(n)和h(n)确定的f(n),并以f(n)的参考权值确定搜索的方向,f(n) = g(n) + h(n)在这里,h(n)表示送起点S出发到n走过的路径长度,g(n)表示从n到终点T的最短路径的长度,在这个问题中g(n)是完美估价,搜索的方向一定是对的。

第k短路可以理解为第k次找到终点,相当于终点被找到k次,即出队k次。

——转载自:传送门

关于A*算法的详细介绍可以参考:关于寻路算法的一些思考,模板可以使用:传送门

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
const int maxn = 1010;
const int inf = 0x3f3f3f3f;
int n, m, s, t, k;
bool vis[maxn];
int dist[maxn];

struct Node
{
    int v, c;
    Node (int _v = 0, int _c = 0): v(_v), c(_c) {}
    bool operator < (const Node &rhs) const
    {
        return c + dist[v] > rhs.c + dist[rhs.v]; // 估价函数 fx = gx + hx 路径短先出队
    }
};

struct Edge
{
    int to, cost;
    Edge (int _to = 0, int _cost = 0): to(_to), cost(_cost) {}
};

vector <Edge> E[maxn], revE[maxn];

void addedge(int u, int v, int w)
{
    E[v].push_back(Edge(u, w)); // 反向加边
    revE[u].push_back(Edge(v, w)); // 正向加边
}

void dijkstra(int s, int n) // 最短路
{
    for (int i = 0; i <= n; ++i)
    {
        vis[i] = false;
        dist[i] = inf;
    }
    dist[s] = 0;
    priority_queue <Node> Q;
    Q.push(Node(s, dist[s]));
    while (!Q.empty())
    {
        Node tmp = Q.top();
        Q.pop();
        int u = tmp.v;
        if (vis[u])
            continue;
        vis[u] = true;
        for (int i = 0; i < E[u].size(); ++i)
        {
            int v = E[u][i].to, cost = E[u][i].cost;
            if (!vis[v] && dist[v] > dist[u] + cost)
            {
                dist[v] = dist[u] + cost;
                Q.push(Node(v, dist[v]));
            }
        }
    }
}

int astar(int s)
{
    priority_queue <Node> Q;
    Q.push(Node(s, 0));
    k--;
    while (!Q.empty())
    {
        Node tmp = Q.top();
        Q.pop();
        int u = tmp.v;
        if (u == t)
        {
            if (k)
                --k;
            else  // 第k次到达目标节点t
                return tmp.c;
        }
        for (int i = 0; i < revE[u].size(); ++i)
        {
            int v = revE[u][i].to, cost = revE[u][i].cost;
            Q.push(Node(v, tmp.c + cost));
        }
    }
    return -1;
}

int main()
{
    int u, v, w;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        for (int i = 0; i <= n; ++i)
        {
            E[i].clear();
            revE[i].clear();
        }
        for (int i = 0; i < m; ++i)
        {
            scanf("%d%d%d", &u, &v, &w);
            addedge(u, v, w);
        }
        scanf("%d%d%d", &s, &t, &k);
        dijkstra(t, n); // t点到所有点的最短路
        if (dist[s] == inf)
            printf("-1\n");
        else
        {
            if (s == t) // 起点等于终点特判
                ++k;
            printf("%d\n", astar(s));
        }
    }
    return 0;
}

The end.
2018-09-09 星期日