MENU

HDU2767 Proving Equivalences(Tarjan 缩点)

2018 年 07 月 16 日 • 阅读: 1363 • 图论阅读设置

Proving Equivalences

  • Time Limit: 4000/2000 MS (Java/Others)
  • Memory Limit: 32768/32768 K (Java/Others)
  • Total Submission(s): 8758
  • Accepted Submission(s): 3110

Problem Description

Consider the following exercise, found in a generic linear algebra textbook.
Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.
Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!
I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:
* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:
* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3

Sample Output

4
2

Source

NWERC 2008


链接

http://acm.hdu.edu.cn/showproblem.php?pid=2767

题意

将推导关系建图,问题转化为给出n个节点m条边的有向图,问至少还需要添加多少条边使得整个图变成一个强连通图。

题解

Tarjan求强连通分量缩点得到DAG,然后判断入度为0的节点的数量cnt1,出度为0的节点的数量cnt2,那么答案就是max(cnt1, cnt2),如果整个图为一个强连通分量,那么答案就是0。

具体可参考POJ1236 Network of Schools

代码

StatusAccepted
Time202ms
Memory4152kB
Length2270
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <stack>
#include <vector>
#include <queue>
using namespace std;

const int maxn = 20010;
int dfn[maxn], low[maxn], sccno[maxn], sccnum[maxn], dp[maxn], indegree[maxn], outdegree[maxn];
int n, m, tot, scccnt;
bool vis[maxn];
vector <int> E[maxn];
stack <int> S;

void init()
{
    tot = scccnt = 0;
    for (int i = 0; i <= n; ++i)
    {
        dfn[i] = low[i] = sccno[i] = sccnum[i] = indegree[i] = outdegree[i] = 0;
        dp[i] = -1;
        vis[i] = false;
        E[i].clear();
    }
}

void tarjan(int u) // 求强连通分量
{
    low[u] = dfn[u] = ++tot;
    S.push(u);
    vis[u] = true;
    for (int i = 0; i < E[u].size(); ++i)
    {
        int v = E[u][i];
        if (!dfn[v])
        {
            tarjan(v);
            low[u] = min(low[u], low[v]);
        }
        else if (vis[v])
            low[u] = min(low[u], dfn[v]);
    }
    if (low[u] == dfn[u])
    {
        scccnt++;
        while (1)
        {
            int v = S.top();
            S.pop();
            vis[v] = false;
            sccno[v] = scccnt;
            sccnum[scccnt]++;
            if (v == u)
                break;
        }
    }
}

void find_scc()
{
    for (int i = 1; i <= n; ++i)
    {
        if (!dfn[i])
            tarjan(i);
    }
}

int main()
{
    int T, u, v;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d", &n, &m);
        init();
        for (int i = 0; i < m; ++i)
        {
            scanf("%d%d", &u, &v);
            E[u].push_back(v);
        }
        find_scc();
        for (u = 1; u <= n; ++u) // 缩点后求入度出度
        {
            for (int i = 0; i < E[u].size(); ++i)
            {
                int v = E[u][i];
                if (sccno[u] != sccno[v])
                {
                    outdegree[sccno[u]]++;
                    indegree[sccno[v]]++;
                }
            }
        }
        int cnt1 = 0, cnt2 = 0;
        for (int i = 1; i <= scccnt; ++i) // 分别计算入度出度为0的点的数量
        {
            if (indegree[i] == 0)
                cnt1++;
            if (outdegree[i] == 0)
                cnt2++;
        }
        if (scccnt == 1) // 整个图强连通
            printf("0\n");
        else
            printf("%d\n", max(cnt1, cnt2));
    }
    return 0;
}

The end.
2018-07-16 星期一