MENU

POJ1144 Network(Tarjan求割点)

2018 年 07 月 16 日 • 阅读: 1106 • 图论阅读设置

Network

  • Time Limit: 1000MS
  • Memory Limit: 10000K
  • Total Submissions: 16390
  • Accepted: 7384

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is  possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate.

The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure  occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated  by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5 
5 1 2 3 4 
0 
6 
2 1 3 
5 4 6 2 
0 
0

Sample Output

1 2

Hint

You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

Source

Central Europe 1996


链接

http://poj.org/problem?id=1144

题意

求无向图割点的数量。

题解

裸的Tarjan,测试一下板子,求无向图的割点和桥。对了,这题的输入有点奇葩,需要特殊处理一下。

代码

StatusAccepted
Time0ms
Memory132kB
Length1463
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
using namespace std;
const int maxn = 110;
int dfn[maxn], low[maxn];
bool cut[maxn];
int n, cnt, tot, rootson;
vector <int> E[maxn];

void init()
{
    for (int i = 0; i <= n; ++i)
    {
        dfn[i] = low[i] = 0;
        cut[i] = false;
        E[i].clear();
    }
    cnt = tot = rootson = 0;
}

void tarjan(int u, int fa)
{
    low[u] = dfn[u] = ++tot;
    for (int i = 0; i < E[u].size(); ++i)
    {
        int v = E[u][i];
        if (!dfn[v])
        {
            tarjan(v, u);
            low[u] = min(low[u], low[v]);
            if (low[v] >= dfn[u] && u != 1)
                cut[u] = true;
            else if (u == 1) // 统计根节点子树的数量,数量大于2,根节点就是割点
                rootson++;
//          if (low[v] > dfn[u]) // 桥的条件
//              printf("%d %d\n", u, v);
        }
        else if (v != fa) // v是u的父亲,那么出现重边,有重边那么一定不是桥,在这里为表示无向边的“第二条边”,非反向边(回边)
            low[u] = min(low[u], dfn[v]); // 注意dfn[v]不一定等于low[v]
    }
}

int count()
{
    tarjan(1, 0);
    if (rootson > 1) // 判断根节点
        cut[1] = true;
    for (int i = 1; i <= n; ++i) // 割点数量
        if (cut[i])
            cnt++;
    return cnt;
}

int main()
{
    while (scanf("%d", &n) != EOF && n)
    {
        init();
        int u, v;
        while (scanf("%d", &u) && u)
        {
            while (getchar() != '\n')
            {
                scanf("%d", &v);
                E[u].push_back(v);
                E[v].push_back(u);
            }
        }
        printf("%d\n", count());
    }
}

才知道在vjudge交题目没有显示时间的话可能是0ms。


The end.
2018-07-16 星期一