MENU

POJ1274 The Perfect Stall (二分图最大匹配)

2018 年 05 月 15 日 • 阅读: 922 • 图论阅读设置

The Perfect Stall

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 28130Accepted: 12379

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

Source

USACO 40


链接

http://poj.org/problem?id=1274

题意&题解

二分图最大匹配裸题,使用匈牙利算法即可。

代码

StatusAccepted
Memory176kB
Length1079
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 210;
bool line[maxn][maxn];
int match[maxn];
bool vis[maxn];
int n, m, k, t;

bool find(int x)
{
    for (int i = 1; i <= m; ++i)
    {
        if (line[x][i] && !vis[i])
        {
            vis[i] = true;
            if (!match[i] || find(match[i]))
            {
                match[i] = x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    int ans;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        memset(line, 0, sizeof(line));
        memset(match, 0, sizeof(match));
        for (int i = 1; i <= n; ++i)
        {
            scanf("%d", &k);
            for (int j = 1; j <= k; ++j)
            {
                scanf("%d", &t);
                line[i][t] = 1;
            }
        }
        ans = 0;
        for (int i = 1; i <= n; ++i)
        {
            memset(vis, 0, sizeof(vis));
            if (find(i))
                ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}

这道题确实太水了,罪过。


The end.
2018-05-15 星期二
最后编辑于: 2018 年 07 月 30 日