MENU

POJ1860 Currency Exchange(最短路)

2018 年 08 月 14 日 • 阅读: 916 • 图论阅读设置

Currency Exchange

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 36534 Accepted: 14029

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion


链接

http://poj.org/problem?id=1860

题意

城市中有n种货币m个货币兑换点,货币兑换点的规则是:A兑换B,汇率为RAB,费用为CAB,B兑换A,汇率为RBA,费用为CBA。比如将100美元兑换成俄元,汇率是29.75,费用为0.39,那么可以兑换到(100-0.39)*29.75俄元。现在某人有第一些第S种货币,问能否在若干次交换后增加他的现金,这些现金最终仍是第S种货币。

题解

从第S类货币开始兑换其他货币,最后还是要换回第S种货币,所以至少存在一个环使得最后能回到S,但是要使得钱数增加,所以必须是正环。问题转化为判断图中是否存在正环,使用bellman_ford算法即可判断,SPFA同样适用。
建图方式:n种货币看成n个结点,将每个兑换点转化为两条有向边。

代码

StatusAccepted
Time32ms
Memory688kB
Length1664
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int inf  = 0x3f3f3f3f;
const int maxn = 110;
double dist[maxn];
int n, m, s;
double sval;
struct Edge
{
    int u, v;
    double val, cost;
    Edge () {}
    Edge (int _u = 0, int _v = 0, double _val = 0, double _cost = 0):u(_u), v(_v), val(_val), cost(_cost) {}
};
vector <Edge> E;

bool bellman_ford(int start)
{
    // 与判断负权回路相反
    for (int i = 1; i <= n; ++i) // 初始化为0
        dist[i] = 0.0;
    dist[start] = sval; // 起点
    for (int i = 1; i < n; ++i)
    {
        bool flag = false;
        for (int j = 0; j < E.size(); ++j)
        {
            int u = E[j].u, v = E[j].v;
            double val = E[j].val, cost = E[j].cost;
            if (dist[v] < (dist[u] - cost) * val) // 更新
            {
                dist[v] = (dist[u] - cost) * val;
                flag = true;
            }
        }
        if (!flag)
            break;
    }
    for (int i = 0; i < E.size(); ++i)
    {
        int u = E[i].u, v = E[i].v;
        double val = E[i].val, cost = E[i].cost;
        if ((dist[u] - cost) * val > dist[v]) // 存在正权回路
            return true;
    }
    return false;
}

int main()
{
    int a, b;
    double va, ca, vb, cb;
    while (scanf("%d%d%d%lf", &n, &m, &s, &sval) != EOF)
    {
        E.clear();
        for (int i = 0; i < m; ++i)
        {
            scanf("%d%d%f%f%f%f", &a, &b, &va, &ca, &vb, &cb);
            E.push_back(Edge(a, b, va, ca));
            E.push_back(Edge(b, a, vb, cb));
        }
        bool flag = bellman_ford(s);
        if (flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

不知道为什么,在Vjudge交URAL的时候过不了,一直WA,但是在POJ上就能过,网上找的代码交URAL同样是WA。

The end.
2018-08-14 星期二
最后编辑于: 2018 年 08 月 19 日