MENU

POJ3352 Road Construction(Tarjan求双连通分量缩点)

2018 年 07 月 18 日 • 阅读: 1372 • 图论阅读设置

Road Construction

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 13401Accepted: 6758

Description

It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

Source

CCC 2007


链接

http://poj.org/problem?id=3352

题意

n个节点m条边的无向图,问至少需要添加多少条边使这个图变成边双连通的。

题解

使用Tarjan求双连通分量,然后将同一个双连通分量缩点构成成一棵树,统计树上度为1的节点的数量cnt,需要添加边的数量就是(cnt+1)/2。貌似这题的数据是没有重边的

具体可参考BYVoid大佬的题解

题目大意是,给定一个连通图,要求添加一些边,使每两个顶点之间都有至少两条不相交的路径,求最小需要添加的边数。

很显然,题中要求的图就是一个边双连通图,即边连通度不小于2。我的方法是在原图中DFS求出所有的桥,然后删除这些桥边,剩下的每个连通块都是一个双连通子图。把每个双连通子图收缩为一个顶点,再把桥边加回来,最后的这个图一定是一棵树,边连通度为1。统计出树中度为1的节点的个数,即为叶节点的个数,记为leaf。有人说至少在树上添加(leaf+1)/2条边,就能使树达到边二连通,所以结果就是(leaf+1)/2。

这个结论我不能证明,但是可以想象出是对的。简单说明一下,首先把两个最近公共祖先最远的两个叶节点之间连接一条边,这样可以把这两个点到祖先的路径上所有点收缩到一起,因为一个形成的环一定是双连通的。然后再找两个最近公共祖先最远的两个叶节点,这样一对一对找完,恰好是(leaf+1)/2次,把所有点收缩到了一起。

这道题跟pku3352一模一样,拿这个程序交两个题一个字不用改都能AC!但实际上两个题也稍有不同,这个题有一点很不容易被注意到,就是可能存在重边,两个点之间如果存在有重边,也算是双连通的。我的处理方法是在DFS时标记每条边及其反向边是否被访问过,而不是判断顶点。

代码

StatusAccepted
Time47ms
Memory376kB
Length4295
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>
using namespace std;
const int maxn = 5010;

int n, m, tot, cnt, cccnt;
int dfn[maxn], low[maxn], head[maxn], ccno[maxn], ccnum[maxn], degree[maxn];
bool vis[maxn];

struct Edge
{
    int to, next;
}edge[20010];
stack <int> S;

void addedge(int u, int v)
{
    edge[cnt].to = v;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}

void init()
{
    for (int i = 0; i <= n; ++i)
    {
        dfn[i] = low[i] = ccno[i] = ccnum[i] = degree[i] = 0;
        head[i] = -1;
        vis[i] = false;
    }
    memset(edge, 0, sizeof(edge));
    tot = cccnt = 0;
    cnt = 1;
}

void tarjan(int u, int father) // 求双连通分量
{
    low[u] = dfn[u] = ++tot;
    S.push(u);
    vis[u] = true;
    bool flag = true;
    for (int i = head[u]; i != -1; i = edge[i].next)
    {
        int v = edge[i].to;
        if (v == father && flag) // 重边处理
        {
            flag = false;
            continue;
        }
        if (!dfn[v])
        {
            tarjan(v, u);
            low[u] = min(low[u], low[v]);
        }
        else if (vis[v])
            low[u] = min(low[u], dfn[v]);
    }
    if (low[u] == dfn[u]) // 栈中保存的是同一个连通分量
    {
        cccnt++;
        while (1)
        {
            int v = S.top();
            S.pop();
//            printf("%d %d\n", cccnt, v);
            vis[v] = false;
            ccno[v] = cccnt;
            ccnum[cccnt]++;
            if (v == u)
                break;
        }
    }
}

int main()
{
    scanf("%d%d", &n, &m);
    init();
    int u, v;
    for (int i = 0; i < m; ++i)
    {
        scanf("%d%d", &u, &v);
        addedge(u, v);
        addedge(v, u);
    }
    tarjan(1, 0);
    for (int i = 1; i <= n; ++i) // 缩点成树求节点的度
    {
        for (int j = head[i]; j != -1; j = edge[j].next)
        {
            int v = edge[j].to;
            if (ccno[i] != ccno[v])
                degree[ccno[i]]++;
        }
    }
    int ans = 0;
    for (int i = 1; i <= cccnt; ++i)
    {
        if (degree[i] == 1) // 找到度为1的节点
            ans++;
    }
    printf("%d\n", (ans+1) / 2); // 至少需要添加的边数
    return 0;
}

推荐阅读

用Tarjan算法求双连通分量的时候,并不是low数组中值不同的就不再同一个双联通分量。

很多大牛的博客都只借助low数组中的值来判断是否是同一个双联通分量。的确low数组中值相同的一定是双连通,但通过Tarjan处理过的low不同也有可能是双连通。我们开始学习Tarjan算法时有一个手写栈,每一次弹栈的时候弹出来的点是一个双联通分量才对。

若要使得任意一棵树,在增加若干条边后,变成一个双连通图,那么

至少增加的边数 =( 这棵树总度数为1的结点数 + 1 )/ 2


The end.
2018-07-18 星期三